[RESOLVED] Reports of Webflow Dashboard Loading Slowly

Incident Report for Webflow

Resolved

Between 18:45 UTC and 19:10 UTC, we saw increased loads times for some customers when accessing the Webflow Dashboard

Our engineering team has identified and addressed the underlying issue and are continuing to monitor the fix.
We sincerely apologize for the disruption and appreciate your patience while we worked to resolve this outage.
Posted Sep 04, 2025 - 18:45 UTC