Collection items for some sites failed to load between 10:24 AM EST to 11:01 AM EST
Incident Report for Webflow
Resolved
The issue no longer occurs, CMS items load on site refresh.

If you are experiencing 404s on your published site, please republish. If the issue consists, please reach out to our support team.
Posted Oct 07, 2021 - 15:18 UTC
Update
We are continuing to investigate this issue.
Posted Oct 07, 2021 - 15:01 UTC
Update
We are continuing to investigate this issue.
Posted Oct 07, 2021 - 14:25 UTC
Investigating
We are currently investigating the issue.
Posted Oct 07, 2021 - 14:24 UTC
This incident affected: Hosted Websites (Static pages).