[RESOLVED] Reports of "Refresh required to continue" errors when opening the Webflow Canvas

Incident Report for Webflow

Resolved

We’re no longer seeing customer impact related to this issue, and functionality has returned to normal. This incident is now resolved.

We appreciate your patience while we worked to resolve this issue.
Posted Apr 02, 2026 - 07:55 UTC

Monitoring

We’ve identified the cause of an issue where some customers see a "Refresh required to continue" message when opening the Webflow Canvas, preventing editing as expected.

As a temporary mitigation, our team is assisting impacted customers directly while we work toward a full resolution. We are also waiting for underlying systems to fully recover.

We’ll continue to share updates as progress is made.
Posted Apr 02, 2026 - 06:03 UTC

Investigating

We’re currently investigating reports that some customers are seeing a "Refresh required to continue" message when opening the Webflow Canvas, preventing them from editing sites as expected.

Our team is actively working to identify the cause of this issue and will share an update as soon as more information becomes available.
Posted Apr 02, 2026 - 05:30 UTC
This incident affected: Webflow Canvas.