Reports of Webflow Dashboard loading slowly
Incident Report for Webflow
Resolved
This incident has been resolved.
Posted Sep 27, 2022 - 19:49 UTC
Monitoring
The Webflow Dashboard and Designer should now be loading as expected. Our team is continuing to monitor for any further issues.
Posted Sep 27, 2022 - 18:49 UTC
Update
The Dashboard should now be loading for customers but some customers may be experiencing latency in the Designer. Our team continue to investigate.
Posted Sep 27, 2022 - 15:09 UTC
Update
We continue to investigate some reports of the Webflow Dashboard loading slowly.
Posted Sep 27, 2022 - 05:48 UTC
Investigating
We've received reports of issues loading the Webflow Dashboard. The Dashboard may load slowly or result in a Timeout error. Our team is actively investigating this.
Posted Sep 27, 2022 - 05:17 UTC
This incident affected: Dashboard.