Reports of degraded performance in Dashboard

Incident Report for Webflow

Resolved

This incident has been resolved. Users may have experienced degraded performance when loading the Dashboard from to 4:00 - 13:40 UTC
Posted Jul 16, 2025 - 20:32 UTC

Monitoring

We are observing improvements in Dashboard performance and are continuing to monitor the situation.
Posted Jul 16, 2025 - 16:31 UTC

Update

Webflow is continuing to investigate reports of degraded performance in the Dashboard for some customers.
Posted Jul 16, 2025 - 14:55 UTC

Update

Webflow is continuing to investigate reports of degraded performance in the Dashboard for some customers.
Posted Jul 16, 2025 - 12:40 UTC

Update

Webflow is still investigating reports of degraded performance in the Dashboard for some customers.
No user action is required at this time
Posted Jul 16, 2025 - 10:23 UTC

Investigating

Webflow is investigating reports of degraded performance in the Dashboard for some customers.
No user action is required at this time.
Posted Jul 16, 2025 - 07:23 UTC
This incident affected: Dashboard.