Webflow Dashboard, Designer and Editor Performance
Incident Report for Webflow
Resolved
Since deploying fixes earlier today, we have seen a full return to expected platform performance.
Posted Oct 14, 2022 - 23:13 UTC
Identified
We have identified a contributing factor which we have remediated, restoring Designer, Dashboard, and Editor to pre-incident performance for the majority of customers. We will continue to monitor the situation throughout the weekend and are actively working to restore functionality to the users who are still impacted.
Posted Oct 14, 2022 - 15:08 UTC
Update
We continue to see stable performance across the Webflow Dashboard, Designer and Editor. Our teams will continue to monitor the issue.
Posted Oct 14, 2022 - 08:45 UTC
Update
We continue to see stable performance across the Webflow Dashboard, Designer and Editor. Our teams will continue to monitor the issue.
Posted Oct 14, 2022 - 03:24 UTC
Update
We have seen steady performance of the Webflow Dashboard, Designer and Editor since deploying changes earlier today. Our team is continuing to investigate, deploy additional changes and monitor performance.
Posted Oct 13, 2022 - 22:48 UTC
Update
We have identified a few potential causes for the latency issues affecting the Webflow Dashboard, Designer and Editor. We have begun implementing changes and are seeing positive improvements in performance and are continuing to monitor changes.
Posted Oct 13, 2022 - 16:41 UTC
Update
Our team is continuing to implement changes to improve the performance issues of the Dashboard, Designer, and Editor. We are monitoring the impact of those changes and still actively investigating.
Posted Oct 13, 2022 - 09:22 UTC
Update
Our team is continuing to implement changes to improve the performance issues of the Dashboard, Designer, and Editor. We are monitoring the impact of those changes and still actively investigating.
Posted Oct 13, 2022 - 04:27 UTC
Update
We're continuing to monitor issues with loading the Dashboard, Designer and Editor. We have seen performance start to stabilize and improve. We expect our next update to be in 6 hours.
Posted Oct 12, 2022 - 22:44 UTC
Update
We are continuing to monitor the changes we have implemented and are seeing reports of increased performance.
Posted Oct 12, 2022 - 21:33 UTC
Update
We are continuing to monitor the changes we have implemented to improve the performance issues with the Dashboard, Designer, and Editor.
Posted Oct 12, 2022 - 19:46 UTC
Update
Our teams have begun implementing changes to improve the performance issues of the Dashboard, Designer, and Editor. We are monitoring the impact of those changes and still actively investigating.
Posted Oct 12, 2022 - 17:29 UTC
Update
We are continuing to investigate reports of issues loading the Webflow Dashboard, Designer and Editor.
Posted Oct 12, 2022 - 16:06 UTC
Update
We are continuing to investigate reports of issues loading the Webflow Dashboard and Designer.
Posted Oct 12, 2022 - 11:48 UTC
Update
We are continuing to investigate reports of issues loading the Webflow Dashboard and Designer.
Posted Oct 12, 2022 - 09:46 UTC
Investigating
Webflow is investigating some reports of issues loading the Webflow Dashboard and Designer. The Dashboard or Designer may load slowly or result in a Timeout error.
Posted Oct 12, 2022 - 05:05 UTC
This incident affected: Dashboard.