Delays with accessing the Webflow Dashboard
Incident Report for Webflow
Resolved
This incident has been resolved.
Posted 21 days ago. Jul 02, 2019 - 15:12 UTC
Monitoring
A fix has been implemented by an upstream CDN provider and we are monitoring the situation closely.
Posted 21 days ago. Jul 02, 2019 - 14:25 UTC
Identified
We are investigating delayed access to the Webflow dashboard caused by an upstream CDN provider outage.
Posted 21 days ago. Jul 02, 2019 - 14:06 UTC
This incident affected: Dashboard.