Reports of form submission notifications being delayed or not delivered at all

Incident Report for Webflow

Resolved

This incident has been resolved.
Posted Jun 22, 2023 - 20:48 UTC

Update

Webflow Form submissions are being delivered, but there may be some latency in delivery until the upstream provider is fully stabilized.
Posted Jun 22, 2023 - 20:37 UTC

Monitoring

Upstream provider has deployed fix and Webflow Form submissions are starting to be delivered again.
Posted Jun 22, 2023 - 19:37 UTC

Update

We are currently working with our upstream provider as they continue to investigate this incident
Posted Jun 22, 2023 - 18:29 UTC

Update

Our upstream provider is continuing to investigate this incident
Posted Jun 22, 2023 - 17:16 UTC

Identified

One of Webflow’s upstream providers is having issues with their services. This is resulting in form submission notifications to be delayed or not delivered at all. We’re closely monitoring this and working to improve form submission notifications.
Posted Jun 22, 2023 - 15:17 UTC

Investigating

We are investigating reports of Form submission notifications being delayed or not delivered at all
Posted Jun 22, 2023 - 14:43 UTC
This incident affected: Email Notifications.