Reports of some customers unable to submit forms or access the forms tab

Incident Report for Webflow

Resolved

This incident has been resolved.
Posted May 21, 2025 - 17:42 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 21, 2025 - 17:35 UTC

Investigating

We are currently investigating issues where some customers are unable to submit forms or access the forms tab via the Webflow Dashboard.
Posted May 21, 2025 - 16:31 UTC
This incident affected: Hosted Websites (Forms).