Form submissions not being delivered
Incident Report for Webflow
Resolved
This incident has been resolved.
Posted Jan 28, 2022 - 17:30 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 28, 2022 - 09:15 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 28, 2022 - 09:15 UTC
Identified
The team has identified the issue and is continuing to work on a fix.
Posted Jan 28, 2022 - 09:01 UTC
Investigating
Webflow is investigating reports of email notifications not being delivered for form submissions. While investigations continue, you can see the form submissions from Project Setting → Form tab.
Posted Jan 28, 2022 - 08:21 UTC
This incident affected: API Status.