Form Submission Notification Sending Failures
Incident Report for Webflow
Resolved
This incident has been resolved
Posted Mar 19, 2021 - 23:24 UTC
Monitoring
We have confirmed with our upstream provider that form email notifications have resumed sending as normal. We will continue to closely monitor the situation throughout the day.

If you are still experiencing sending delays or missing form email notifications, please reach out to Webflow Customer Support.
Posted Mar 19, 2021 - 14:21 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 19, 2021 - 05:50 UTC
Update
We are continuing to work with our upstream provider to bring form email notifications back to full working order. Currently, backlogged emails are being sent out in hourly batches, but we don't yet have an estimate for when delivery will occur in real time.

In the meantime, site owners can still access their form submissions in the "Forms" tab of their site settings, and Collaborators will still see responses in the "Forms" tab of the Editor.
Posted Mar 19, 2021 - 05:47 UTC
Update
We are continuing to work with our provider on a fix for our form notification emails.

We will update you as they begin to send again.

In the meantime, site owners can still access their form submissions in the "Forms" tab of their site settings, and Collaborators will still see responses in the "Forms" tab of the Editor.
Posted Mar 19, 2021 - 01:32 UTC
Identified
Site owners are not currently being notified of form submissions via email. We have identified an issue with an upstream service provider and are working with them to resolve it.

In the meantime, site owners can still access their form submissions in the "Forms" tabs of their site settings, and Collaborators will still see responses in the "Forms" tab of the Editor.

We will continue to update you as we receive more info from our upstream provider.
Posted Mar 18, 2021 - 22:10 UTC
This incident affected: Dashboard.