Customers were unable to load Webflow Canvas and the Dashboard between 19:28 and 20:20 UTC. The issue has now been resolved and services are operating normally. Thank you for your patience while we addressed this issue.
Posted Mar 13, 2026 - 20:49 UTC
Monitoring
A fix has been implemented and the Webflow Canvas is loading again for customers. Our team is continuing to monitor the situation closely to ensure everything remains stable. Thank you for your patience while we worked to resolve this issue.
Posted Mar 13, 2026 - 20:24 UTC
Update
We are continuing to investigate this issue.
Posted Mar 13, 2026 - 20:14 UTC
Investigating
We’re investigating reports that customers are unable to load the Webflow Canvas. Our team is actively investigating and will share another update as soon as we have more information. We appreciate your patience while we work on this.
Posted Mar 13, 2026 - 19:59 UTC
This incident affected: Dashboard and Webflow Canvas.