Reports of form notification emails not being delivered

Incident Report for Webflow

Update

Work to restore full functionality to form submission notification emails is ongoing with the support of our upstream provider. In the meantime, form submissions can still be reviewed via the Forms tab in Site Settings. We sincerely appreciate your patience and understanding and will share another update as soon as new information is available.
Posted Feb 10, 2026 - 21:22 UTC

Update

With the support of our upstream provider, the required actions to resolve the issue have been identified and work is ongoing. We will share another update as soon as a new information is available, and sincerely appreciate your patience and understanding as we work to restore this functionality. In the meantime, Form submissions can be accessed via the Forms tab in Site Settings.
Posted Feb 10, 2026 - 18:02 UTC

Identified

We’ve identified that this behaviour is arising due to an issue with an upstream provider. We’re actively working with them to resolve the issue and restore normal notification delivery as soon as possible. Form submissions themselves are not impacted, and can still be reviewed via the forms tab in site settings as expected.
Posted Feb 10, 2026 - 16:30 UTC

Investigating

We’re investigating reports that form notification emails are not being delivered as expected for some customers. Our team is actively investigating and will share another update as soon as we have more information. In the meantime, form submissions can be reviewed via the forms tab in site settings.
Posted Feb 10, 2026 - 16:11 UTC
This incident affects: Email Notifications.