Widespread Internet Outage

Incident Report for Webflow

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 21:05 UTC

Monitoring

We are aware of the current reports regarding a widespread internet outage and are actively monitoring our services. Please note that third-party applications integrated with Webflow may also be affected. At this time, our services are unaffected and stable.
Posted Jun 12, 2025 - 19:00 UTC