[RESOLVED] Reports of issues with form submission notification emails

Incident Report for Webflow

Resolved

This incident is now resolved.

Between 17:55 and 20:35 UTC (10:55 AM–1:35 PM PT), form submission notification emails were not sent as expected. During this time, form submissions were successfully collected and remain available in the Forms tab within Site settings. However, notification emails that were not sent during this window will not be delivered retroactively.

A fix was deployed, and email delivery has been fully restored. We are no longer seeing customer impact related to this issue.

We appreciate your patience while we worked to resolve this.
Posted Mar 10, 2026 - 20:58 UTC

Identified

We’re currently investigating an issue where form submission notification emails are not being delivered as expected.

Form submissions themselves are still being successfully collected and can be accessed in the Forms tab within Site settings. However, customers will not receive email notifications for new submissions at this time.

Our Engineering team is actively investigating the issue and working to restore normal email delivery. We’ll share another update as soon as we have more information.
Posted Mar 10, 2026 - 20:45 UTC
This incident affected: Email Notifications.