Webflow's hosted sites, publishing, Dashboard, and subscription purchasing — are now fully operational.
Earlier impact to a limited number of hosted sites, publishing, and the Webflow Dashboard occurred between 15:00 UTC and 20:00 UTC, while subscription purchase issues were observed by a smaller sub-set of customers between 21:00 UTC and 23:00 UTC.
Following a sustained period of stability across these systems, we’ve confirmed that normal functionality has been fully restored. Our team will continue to keep an eye on platform performance to ensure ongoing stability.
We sincerely appreciate your patience and understanding throughout this incident.
Posted Oct 21, 2025 - 01:31 UTC
Update
Hosted sites, publishing, and the Webflow Dashboard are now fully operational.
Some customers may be experiencing issues purchasing Webflow subscriptions. We’re actively tracking this with our upstream provider and will share further updates as more information becomes available.
Thank you for your continued patience while we monitor the situation.
Posted Oct 20, 2025 - 23:24 UTC
Monitoring
We’re seeing publishing speeds return to normal levels and customers can now publish their sites to resolve any remaining 500 or 504 errors on hosted sites.
Publishing was impacted primarily between 15:00 UTC and 20:00 UTC, and any publish attempts made during that window may have resulted in hosted sites returning 500 or 504 errors. Republishing your site should help resolve these.
We understand the disruption this outage caused and sincerely appreciate your patience while we and our upstream provider implemented mitigations. Our team continues to monitor the platform closely to ensure stability across all services.
Posted Oct 20, 2025 - 20:59 UTC
Update
We’re continuing our mitigation efforts to restore publishing functionality and resolve remaining 500 and 504 errors on hosted sites. These efforts are progressing alongside ongoing mitigations reported by our upstream provider.
The Webflow Dashboard has fully recovered and is operational. We’ll continue to monitor closely while work continues to restore full functionality for hosted sites and publishing.
We’ll share another update as soon as more information is available.
Posted Oct 20, 2025 - 18:35 UTC
Identified
We’ve identified that the 500 and 504 errors on hosted sites were caused by an issue with an upstream provider that disrupted Webflow functionality. Our team is actively working on mitigations to restore stability across all affected services.
To support these mitigation efforts and prevent additional errors, publishing remains temporarily disabled at this time.
We’ll continue to share updates as recovery progresses.
Posted Oct 20, 2025 - 17:23 UTC
Update
We’re continuing to investigate 500 and 504 errors on some hosted sites along with issues preventing some users from publishing sites or accessing the Webflow Dashboard.
To prevent additional errors on hosted sites, we will temporarily be disabling the ability to publish sites and you may receive an error when attempting to do so.
We apologize for the impact this may have and are working urgently to restore full functionality.
Posted Oct 20, 2025 - 16:05 UTC
Update
We are continuing to investigate this issue.
Posted Oct 20, 2025 - 15:39 UTC
Investigating
We’re currently investigating issues that is causing 500 and 504 errors on some hosted sites and preventing some users from publishing sites or accessing the Webflow Dashboard. Our team is working urgently to identify the root cause and restore full functionality.
We're confirming if this related to issues reported earlier regarding our upstream provider.
We’ll share another update as soon as more information becomes available.
Posted Oct 20, 2025 - 15:34 UTC
Monitoring
Note: This update was delayed because the incident affected our ability to post to the status page. We posted a banner on support.webflow.com to let customers know about the ongoing impact.
At 07:10 UTC on October 20, an issue with an upstream provider caused disruption to Webflow functionality. Some users were unable to publish sites, access the Dashboard or perform actions within Webflow such as restoring backups or exporting code. From 09:40 UTC, we began to see significant recovery and customers should be able to access and use Webflow again as expected. We'll continue to monitor the situation.
If your site is has remained in a “Restore in progress” state for an extended period of time, please contact Support via support.webflow.com for assistance.
Posted Oct 20, 2025 - 11:48 UTC
This incident affected: Hosted Websites (Static pages, CMS pages) and Dashboard, Designer, Publishing.