Between 3:00 PM PT and 6:35 PM PT, customer-configured outbound webhooks were not being delivered as expected.
This issue has now been resolved, and outbound webhook delivery is operating normally. Any form submissions received during this time were still successfully processed and remain available in the Forms tab within Site settings.
Posted Jul 28, 2026 - 02:13 UTC
Identified
We have identified the issue affecting outgoing Webhooks. Customer-configured Webhooks are currently failing and are not being delivered as expected.
Our engineering team is actively working to restore Webhook delivery. Forms and form notification emails are operating normally and are not impacted by this issue.
We appreciate your patience and will share another update as soon as more information is available.
Posted Jul 28, 2026 - 01:48 UTC
Investigating
We're investigating reports that outbound webhooks are not being delivered as expected. Our team is actively investigating the issue and working to identify the root cause.
Please note that Form submissions and Form email notifications continue to be received and can be reviewed in the Forms tab within Site settings. We'll share another update as soon as we have more information.
Posted Jul 28, 2026 - 01:18 UTC
This incident affected: API & MCP Server (Data API), Email Notifications, and Hosted Websites (Forms).