SSL Degraded Performance
Incident Report for Webflow
Postmortem

Summary

On Saturday 3:56pm PST (11/11/2017) our SSL infrastructure stack experienced a surge in requests that affected a number of sites hosting on SSL. At 4:45pm PST the infrastructure team started provisioning extra capacity to our SSL stack to handle the load. This was an isolated DDoS attacked directed at one site that caused service disruption to other Webflow hosting customers. The total amount of downtime varied from 25 minutes to 45 minutes for some customers.

Next Steps

We will be taking steps to help isolate sites under attack with various DNS mitigation workflows. We will also continue work on efforts to improve the resiliency of our SSL stack to support the large number of highly trafficked sites transitioning to Webflow Hosting. (Follow up announcement soon).

Posted 9 months ago. Nov 13, 2017 - 19:48 UTC

Resolved
This incident has been resolved.
Posted 9 months ago. Nov 13, 2017 - 19:12 UTC
Monitoring
We noticed a burst of SSL traffic that affected sites for 25 minutes Saturday afternoon PST. We detected the anomaly and provisioned more capacity to deal with the burst in traffic. During this time certain sites hosted on SSL potentially could have been returning 503 errors.
Posted 9 months ago. Nov 13, 2017 - 18:57 UTC