[RESOLVED] Reports of issues logging in to Webflow

Incident Report for Webflow

Resolved

This incident is now resolved. Some customers experienced issues logging in to Webflow between 23:30 UTC on July 14 and 00:30 UTC on July 15. We’re no longer seeing customer impact related to this issue. Thank you for your patience while we worked to resolve this.
Posted Jul 15, 2026 - 02:46 UTC

Monitoring

We’ve implemented a mitigation and are no longer seeing customer impact related to this issue. We’re continuing to monitor the situation closely and will provide another update as soon as we have more information. Thank you for your patience.
Posted Jul 15, 2026 - 00:39 UTC

Update

We are continuing to investigate this issue.
Posted Jul 15, 2026 - 00:23 UTC

Investigating

We’re investigating reports that some customers are unable to log in to Webflow. Our team is actively investigating the issue and working to identify the root cause. We’ll share another update as soon as we have more information. Thank you for your patience.
Posted Jul 15, 2026 - 00:21 UTC
This incident affected: Webflow.com & Marketplace (Webflow.com, University, Support Portal, Marketplace) and Dashboard.