Reports of intermittent issues with video element on hosted sites.
Incident Report for Webflow
Resolved
Webflow’s upstream provider has resolved issues on their end, and Webflow is fully operational.

No user action is required at this time.
Posted Dec 18, 2023 - 01:11 UTC
Update
One of Webflow’s upstream providers is having issues with their services. We're monitoring the situation and will provide updates here.
Posted Dec 17, 2023 - 23:57 UTC
Investigating
One of Webflow’s upstream providers is having issues with their services. As a temporary solution, if you are using YouTube videos, consider using the YouTube element instead of the standard Video element as a workaround.
Posted Dec 17, 2023 - 23:49 UTC
This incident affected: Hosted Websites (Static pages, CMS pages) and Designer (Designer).