Form notification emails are not being sent

Incident Report for Webflow

Resolved

This incident has been resolved.
Posted Feb 05, 2022 - 22:07 UTC

Monitoring

Webflow’s upstream provider has determined a fix and has implemented a solution. No user action is required at this time.
Posted Feb 05, 2022 - 21:48 UTC

Identified

Our upstream mail provider is having an outage in email sending. In the meantime, you can see the form submissions from Project Setting → Form tab.
Posted Feb 05, 2022 - 21:27 UTC
This incident affected: Hosted Websites (Static pages).