Issues logging into Webflow account using Google Sign In
Incident Report for Webflow
Resolved
This incident has been resolved. No user action is required at this time.
Posted Jan 11, 2024 - 02:14 UTC
Identified
The team has identified the issue and is continuing to work on a fix.
Posted Jan 11, 2024 - 01:31 UTC
Investigating
Webflow is investigating reports of issues logging into Webflow through Google Sign In.

While investigations continue, customers can reset their password using the "Forgot Password" link and sign in with their credentials instead of Google Sign In.
Posted Jan 11, 2024 - 00:55 UTC
This incident affected: Dashboard.