Reports of issue purchasing or modifying subscriptions
Incident Report for Webflow
Resolved
This incident has been resolved. If you experienced issues purchasing or modifying a Site plan or Workspace plan, you can now try this action again.
Posted May 15, 2024 - 17:23 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 15, 2024 - 17:10 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 15, 2024 - 17:03 UTC
Investigating
Webflow is investigating reports of issues purchasing or modifying subscriptions such as Site plans & Workspace plans
Posted May 15, 2024 - 16:16 UTC
This incident affected: Dashboard.