Email deliverability issues
Incident Report for Webflow
Resolved
Emails are being sent again, and any emails queued up during the downtime should be delivered. If you're still seeing emails (such as account verification emails, form submission notifications, etc) not arrive in your inbox, please contact our support team at support@webflow.com and we'll investigate. Thank you all for your patience!
Posted 4 months ago. Jun 12, 2018 - 18:32 UTC
Update
During our investigation, we've learned that there has been a very large influx of spam account signups this morning from randomized emails – which caused a big spike of verification emails that caused our email provider to suspend all transactional email delivery. We have deployed a code change to prevent this specific pattern of spam account signups, and are working with our email API provider to bring our account back online. We are being told that this process takes about an hour, and we thank you for your patience.
Posted 4 months ago. Jun 12, 2018 - 16:58 UTC
Identified
We've been notified that our email delivery provider has temporarily disabled our account. We will be working with them to restore service ASAP. Emails such as account verification emails, form notification emails, and other transactions emails are currently impacted.
Posted 4 months ago. Jun 12, 2018 - 14:58 UTC