[RESOLVED] Reports of form submission notification emails not being delivered for some customers

Incident Report for Webflow

Resolved

This incident is now resolved. Form submission notification emails were impacted between 00:46 UTC on September 21 and 15:33 UTC on September 22. New form submissions are now triggering notification emails as expected.

During this time, form submissions continued to be received and saved as expected, and webhook delivery was unaffected. Notification emails that were not delivered during the affected timeframe will not be delivered retroactively.

Affected customers can review submissions from this timeframe via:
- the Forms tab in Site settings
- the data_forms MCP tool
- the Form Submissions API endpoints

We appreciate your patience while we worked with our upstream provider to resolve this issue.
Posted Sep 22, 2026 - 17:05 UTC

Monitoring

There is no longer active customer impact, and form submission notification emails are now being delivered as expected. During this incident, notification email delivery was impacted for some customers. Form submissions continued to be received and saved in Site settings as expected, and webhook delivery was unaffected. Our team is continuing to monitor the situation closely. We appreciate your patience while we worked through this issue.
Posted Sep 22, 2026 - 16:03 UTC

Identified

We’ve identified that this behaviour is arising due to an issue with an upstream provider. We’re actively working with them to resolve the issue and restore delivery of form notification emails as soon as possible. Form submissions themselves are not impacted.

In the meantime, Form submissions can still be reviewed via the Forms tab in Site settings, by using the MCP and Form Submissions API.

We appreciate your continued patience and will share another update as soon as new information is available.
Posted Sep 22, 2026 - 14:30 UTC

Investigating

We’re investigating reports that form submission notification emails are not being delivered as expected for some customers. Our team is investigating and will share another update as soon as we have more information.

In the meantime, Form submissions can still be reviewed via the Forms tab in Site settings, the MCP and Form Submissions API endpoints.
Posted Sep 22, 2026 - 13:01 UTC
This incident affected: Email Notifications.