Form Email Sending Delays
Incident Report for Webflow
Resolved
We have confirmed to now be sending all queued emails again
Posted Apr 16, 2021 - 23:32 UTC
Identified
We believe we have found the issue and are verifying the fix.
Posted Apr 16, 2021 - 23:18 UTC
Investigating
Our upstream form email provider is experiencing delivery delays. When this is resolved, any form emails will be delivered
Posted Apr 16, 2021 - 22:31 UTC
This incident affected: Hosted Websites.