Issues receiving account notification emails for some customers
Incident Report for Webflow
Resolved
This issue is resolved. Newly triggered emails are being sent as expected.
Posted Sep 16, 2024 - 11:06 UTC
Monitoring
Our upstream provider has implemented a fix and have confirmed that their services are now working as expected. As a result, we are now seeing newly triggered emails sent and delivered as expected.

Our team are continuing to monitor the situation and are reviewing the delivery attempts that failed while the issue was present.
Posted Sep 16, 2024 - 10:22 UTC
Update
Our upstream provider have acknowledged the issue, identified the root cause and are working on a fix.
Posted Sep 16, 2024 - 08:24 UTC
Identified
We have identified an issue with one of our upstream providers impacting some email notifications for the following:
- Account verification
- New comments
- Some billing and site updates
- Some Workspace notifications
- Ecommerce notifications (both to site owners and customers)

If you are unable to verify your Webflow account, please contact support.webflow.com
Posted Sep 16, 2024 - 04:03 UTC
Investigating
Webflow is currently investigating issues with our email notifications for account verification, comments, Ecommerce and some other account notifications.
Posted Sep 16, 2024 - 03:37 UTC
This incident affected: Email Notifications.