SSL certificates for new sites are not issued
Incident Report for Webflow
Resolved
This incident has been resolved.
Posted Dec 02, 2021 - 21:35 UTC
Investigating
We are affected by Let's Encrypt certficate issuance problems: https://letsencrypt.status.io/pages/55957a99e800baa4470002da
New sites don't get SSL certificates. Sites with certificates issued earlier are not affected.
Posted Dec 02, 2021 - 19:42 UTC
This incident affected: Hosted Websites (Static pages).