Reports of delayed site publishing time

Incident Report for Webflow

Resolved

This incident has been resolved.
Posted May 06, 2025 - 20:34 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 06, 2025 - 20:05 UTC

Investigating

Webflow is investigating reports of delayed publishing times for some customers.
Posted May 06, 2025 - 19:56 UTC
This incident affected: Publishing.