Reports of some customers unable to access some sites in their Dashboard

Incident Report for Webflow

Resolved

This incident has been resolved. Customers may need to refresh their Dashboard to see any sites that were missing.
Posted Nov 05, 2024 - 23:16 UTC

Monitoring

A fix has been implemented and our team are monitoring the issue. Customers may need to refresh their Dashboard to see any sites that were missing.
Posted Nov 05, 2024 - 22:59 UTC

Investigating

We are currently investigating issues with some customers not able to view or access some sites in their Dashboard.
Posted Nov 05, 2024 - 22:37 UTC
This incident affected: Dashboard.