Reports of some customers unable to submit forms

Incident Report for Webflow

Resolved

This incident has been resolved. To ensure everything works smoothly, please republish your site.
Posted Nov 09, 2024 - 02:04 UTC

Investigating

We are currently investigating issues where some customers are unable to submit forms.
Posted Nov 09, 2024 - 00:24 UTC
This incident affected: Hosted Websites (Forms).