Issues loading the Webflow Dashboard

Incident Report for Webflow

Resolved

This incident has been resolved.
Posted Sep 27, 2024 - 18:31 UTC

Identified

The team has identified the issue and is continuing to work on a fix.
Posted Sep 27, 2024 - 18:21 UTC

Investigating

Webflow is currently investigating issues with the Dashboard
Posted Sep 27, 2024 - 18:07 UTC
This incident affected: Dashboard.