Between 14:19 and 14:43 UTC, some customers experienced issues accessing Webflow. This has now been resolved, and services are operating normally.
We appreciate your patience while we worked to restore service.
Posted Apr 08, 2026 - 15:37 UTC
Monitoring
A fix has been implemented and Webflow is now accessible again. We are continuing to monitor closely to ensure stability and will share another update if anything changes.
Posted Apr 08, 2026 - 14:51 UTC
Identified
We’ve identified the cause of the issue impacting access to Webflow and are working to apply a fix. Our team is focused on restoring access, and we’ll continue to share updates as progress is made.
Posted Apr 08, 2026 - 14:45 UTC
Investigating
We are currently investigating reports that Webflow is unavailable for some customers. Our team is actively working to identify the cause and restore access as quickly as possible. We will share another update as soon as we have more information.
Posted Apr 08, 2026 - 14:36 UTC
This incident affected: Webflow.com & Marketplace (Webflow.com, University, Support Portal, Marketplace) and Dashboard, Webflow Canvas.