Reports some customers are experiencing an influx of spam messages via forms.
Incident Report for Webflow
Resolved
Our team has deployed a spam filtering solution for form submissions, and will continue monitoring.

If you are still experiencing suspicious or spammy form submissions on your website, please reach out to https://support.webflow.com so that we can help investigate.
Posted Jan 26, 2023 - 05:28 UTC
Monitoring
Our team has deployed a remediation measure and we are monitoring the situation. No user action is required at this time.
Posted Jan 26, 2023 - 05:06 UTC
Investigating
Webflow is investigating reports that some customers are experiencing an influx of spam messages via forms.

We understand that receiving spam messages either directly or through your clients can be concerning. If you are experiencing an increase in spam submissions or emails, please ignore them. Rest assured, our security team is actively investigating this incident, we recommend avoiding clicking any links that you receive.

If you have a specific concern please reach out to https://support.webflow.com and we’ll be happy to help you directly.
Posted Jan 26, 2023 - 03:32 UTC
This incident affected: Hosted Websites (Static pages).