[RESOLVED] Increase in Unexpected 404 Errors on a Small Number of Hosted Sites

Incident Report for Webflow

Resolved

Between 7:25pm and 8:00pm UTC on February 26th, a very small number of hosted sites experienced an increase in unexpected 404 errors when accessing site pages.

Upon being alerted to this issue, our team took action to minimize impact and restore full service to the small number of impacted sites a as soon as possible. We apologize for any inconvenience that this issue caused, and appreciate your patience and understanding while we worked to resolve it.
Posted Feb 26, 2026 - 20:00 UTC