System performance degradation
Incident Report for Webflow
Resolved
This incident has been resolved.
Posted May 11, 2020 - 03:28 UTC
Monitoring
Both elevated latency and site publishing delays should be resolved. We are continuing to monitor the situation.
Posted May 11, 2020 - 03:06 UTC
Update
We are also investigating delays in site publishing.
Posted May 11, 2020 - 01:58 UTC
Update
Network latency and timeouts are returning to normal levels. We are still investigating the initial cause of the degraded performance.
Posted May 11, 2020 - 01:51 UTC
Investigating
We are seeing high latency and timeouts across our infrastructure on hosted sites and in the app.
Posted May 11, 2020 - 00:54 UTC
This incident affected: Hosted Websites and Dashboard.