Publishing issues on some sites.

Incident Report for Webflow

Resolved

This incident has been resolved. Some sites may have experienced degraded publishing performance from 17:29 - 17:47 UTC.
Posted Jul 01, 2025 - 19:47 UTC

Monitoring

The team has deployed a fix and we are monitoring the situation.
Posted Jul 01, 2025 - 19:08 UTC

Investigating

Webflow is investigating reports of delayed publishing for some sites.
Posted Jul 01, 2025 - 18:16 UTC
This incident affected: Publishing.