CDN assets not loading as expected in the Designer and hosted sites for customers in Singapore

Incident Report for Webflow

Resolved

The issue impacting the delivery of website assets via our CDN (cdn.prod.website-files.com) for users in Singapore has been resolved. We’ve verified the fix implemented by the third-party provider, and asset requests are now functioning as expected.

If visitors are still unable to access Webflow-hosted sites, we recommend the following:
- Restart your device.
- Clear your browser and DNS caches.
- If the issue persists, contact your local ISP and ask them to check their DNS configuration for cdn.prod.website-files.com.

We appreciate your patience throughout this incident.
Posted Aug 08, 2025 - 17:09 UTC

Monitoring

The root cause of the issue has been addressed by the required third-party. As a result, new requests to our assets CDN (cdn.prod.website-files.com) made by visitors in Singapore should now be served successfully but we are continuing to actively monitor the situation.

We appreciate your patience and understanding as this work continues, and we will share another update as soon as new information is available.
Posted Aug 08, 2025 - 13:47 UTC

Identified

We have identified the root cause of the issue and are currently working with the required third-party stakeholders to resolve the issue as soon as possible.

We have communicated the urgency of this issue with these parties and will share an update as soon as additional information is available.
Posted Aug 08, 2025 - 12:59 UTC

Investigating

Webflow is investigating reports of website assets served through our CDN not loading as expected in the Designer or on hosted sites in Singapore. We are working with providers to investigate their DNS configuration for customers in Singapore. This is not an issue with the Webflow Designer or Dashboard.
Posted Aug 08, 2025 - 11:26 UTC
This incident affected: Hosted Websites (Static pages, CMS pages, Localization, Ecommerce, User Accounts, Forms, Site search, SSL certificate provisioning) and Dashboard, Designer.