Sporadic high latency across hosted sites
Incident Report for Webflow
Resolved
We've mitigate the impact from the DDOS attack. All systems are operating normally and network latency has returned to normal levels. We will follow up with more information and a post-mortem in the near future. Thank you for your patience during this incident.
Posted May 10, 2020 - 17:30 UTC
Monitoring
We have isolated the target of the attack and are mitigating the follow-on effects. Network and hosted site latency is returning to normal levels. We will continue actively monitor the situation while we add network and application capacity.
Posted May 10, 2020 - 13:35 UTC
Identified
We are currently experiencing a large DDoS (Distributed Denial of Service) attack affecting requests in the EU and US West. Some hosted sites may experience elevated latency. Thank you for your patience while we investigate and work to mitigate this attack.
Posted May 10, 2020 - 12:57 UTC
Monitoring
We have identified a problem and a fix has been rolled out. We are no longer seeing elevated latency.
Posted May 10, 2020 - 12:03 UTC
Investigating
We are seeing sporadic high latency on serving websites hosted on Webflow. We are currently investigating this issue.
Posted May 10, 2020 - 11:35 UTC
This incident affected: Hosted Websites (Static pages).