Changes to hosted sites are not getting published
Incident Report for Webflow
Resolved
This incident has been resolved. After publishing your site all changes should be there.
Posted Nov 08, 2021 - 20:17 UTC
Investigating
We are currently investigating this issue.
Posted Nov 08, 2021 - 19:17 UTC
This incident affected: Hosted Websites (Static pages).