Reports of downtime on Webflow.com, Dashboard, Designer and degraded performance on Forms
Incident Report for Webflow
Resolved
This incident has been resolved.
Posted Aug 16, 2023 - 15:04 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 16, 2023 - 14:30 UTC
Identified
The issue has been identified and we are working on a fix.
Posted Aug 16, 2023 - 13:22 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 16, 2023 - 13:06 UTC
Investigating
We are currently investigating reports of downtime on Webflow.com, including the Dashboard and Designer. Users may also experience some degraded performance with Forms on hosted sites.
Posted Aug 16, 2023 - 12:54 UTC
This incident affected: Designer (Designer, Editor, CMS manager, Ecommerce manager, Logic manager, Comments), Webflow.com & Marketplace (Webflow.com, University, Support Portal, Marketplace), and Dashboard.