Reports of Issues accessing the Dashboard and Designer

Incident Report for Webflow

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 17:35 UTC

Monitoring

Our upstream provider have implemented a fix. As a result, we are seeing services return to normal. We are continuing to actively monitor the situation.
Posted Mar 27, 2025 - 17:32 UTC

Identified

We have identified that this behaviour arising due to an outage with an upstream provider. We are currently working with them to identify a fix.
Posted Mar 27, 2025 - 16:38 UTC
This incident affected: Dashboard and Designer.