[RESOLVED] Reports of issues loading Optimize Dashboard for non-Webflow sites

Incident Report for Webflow

Resolved

This issue has been resolved. The Optimize management experience for non-Webflow sites is loading normally. Live optimizations running on customer sites were not affected at any point. Thank you for your patience.
Posted Aug 05, 2026 - 15:59 UTC

Monitoring

We've identified the cause of this issue and applied a fix. The Optimize dashboard for non-Webflow sites should now be loading normally. We're continuing to monitor to confirm the issue is fully resolved.
Posted Aug 05, 2026 - 15:45 UTC

Investigating

We're investigating reports of some customers being unable to open the management experience for Optimize on non-Webflow sites. Our team is actively investigating and we'll share another update as soon as we have more information. Live optimizations are not affected and continue to run.
Posted Aug 05, 2026 - 15:27 UTC
This incident affected: Dashboard.