Reports of slow load times for Dashboard, Designer & hosted websites
Incident Report for Webflow
Resolved
This incident has been resolved.
Posted Apr 20, 2023 - 16:42 UTC
Monitoring
The latencies of any affected services have returned back to normal levels. Hosted websites may have seen slower load times or 504 errors between 12pm UTC and 3pm UTC.
Posted Apr 20, 2023 - 15:40 UTC
Identified
The team has identified the issue and is continuing to work on a fix.
Posted Apr 20, 2023 - 15:31 UTC
Investigating
Webflow is investigating reports of latency in the Dashboard, Designer and on hosted websites.
Posted Apr 20, 2023 - 15:03 UTC
This incident affected: Hosted Websites (Static pages), Designer (Designer), and Dashboard.