New site creation page shows an error for new Webflow accounts.
Incident Report for Webflow
Resolved
This incident has been resolved. No user action is required at this time.
Posted Sep 19, 2022 - 07:15 UTC
Monitoring
The team has deployed a fix for new accounts and we are monitoring the situation.
Posted Sep 18, 2022 - 11:45 UTC
Identified
The team has identified the issue and is continuing to work on a fix.
Posted Sep 18, 2022 - 10:04 UTC
Investigating
Webflow is investigating some reports of new customers seeing a message ‘Error: Something went wrong. Please try again’ on the new site creation page. This is only affecting newly created Webflow accounts. While investigations continue, the page content loads briefly and a new project can be created if selected before the page finishes loading.
Posted Sep 18, 2022 - 09:39 UTC
This incident affected: Dashboard.