Issues with making changes in the Editor
Incident Report for Webflow
Resolved
This incident has been resolved.
Posted Jan 19, 2023 - 05:26 UTC
Identified
The team has identified the issue and is continuing to work on a fix.
Posted Jan 19, 2023 - 02:44 UTC
Investigating
Webflow is investigating reports of some customers unable to make changes to static content in the Editor.
Posted Jan 19, 2023 - 01:56 UTC
This incident affected: Dashboard.