Between approximately 00:00 UTC and 04:05 UTC, some hosted sites experienced slower loading times and SSL certificates took longer than expected to provision. We're no longer seeing customer impact related to this issue. Following confirmation from an upstream provider and verification by our team, this incident is now resolved. Thank you for your patience while our upstream provider worked to resolve this issue.
Posted Jul 02, 2026 - 10:59 UTC
Monitoring
Our upstream provider has implemented a fix, and we’re seeing hosted site loading times and SSL certificate provisioning return to expected performance levels. We’re continuing to monitor the situation closely and will share another update if needed.
Posted Jul 02, 2026 - 04:12 UTC
Identified
The issue is related to an upstream provider. A small number of customers may continue to experience slower loading times on hosted sites or slower SSL certificate provisioning. Our team is actively monitoring the situation and working with our upstream provider. We appreciate your patience and will share another update as soon as more information is available.
Posted Jul 02, 2026 - 02:48 UTC
Investigating
We’re investigating reports that some hosted sites are loading more slowly than expected, and that SSL certificates are taking longer than expected to provision for some customers. We’re currently investigating an issue with an upstream provider that may be contributing to this behavior and are working to restore expected performance. We appreciate your patience and will share another update as soon as more information is available.
Posted Jul 02, 2026 - 00:00 UTC
This incident affected: Hosted Websites (Site Pages, SSL certificate provisioning).