[Resolved] Publishing, webhook delivery failures, and delays in form actions

Incident Report for Webflow

Resolved

The issue affecting publishing, webhook delivery, and form Actions between 22:00 and 22:50 UTC has been fully resolved. All systems are now operating normally, and hosted websites remain fully operational. Some users may need to republish their sites to ensure recent changes are reflected. We appreciate your patience and understanding while our team worked to restore full functionality.
Posted Oct 21, 2025 - 23:18 UTC

Monitoring

A fix has been implemented for the issue affecting publishing, webhook delivery (API), and related form Actions. All hosted websites remain fully operational. Our team is closely monitoring system performance to ensure stability and will provide another update once we’ve confirmed the issue is fully resolved. Thank you for your patience.
Posted Oct 21, 2025 - 23:05 UTC

Identified

We’ve identified the cause of the issue affecting publishing and webhook (API) delivery. Additionally, form-related Actions continue to experience slight delays in processing. All hosted websites remain fully operational. Our team is implementing a fix to restore normal functionality, and we’ll provide another update once recovery is confirmed. Thank you for your continued patience while we work on this.
Posted Oct 21, 2025 - 22:58 UTC

Investigating

We’re investigating an issue that’s preventing publishing and webhook delivery (API) from functioning properly. Additionally, form-related Actions may experience slight delays in processing. All hosted websites are fully operational. Our team is actively investigating the root cause and working to restore normal functionality across all affected services as quickly as possible. We’ll share another update as soon as we have more information. Thank you for your patience while we work to resolve this.
Posted Oct 21, 2025 - 22:34 UTC
This incident affected: Publishing, API Status, and Email Notifications.