Reports of slowness and crashing within the Designer and Editor
Incident Report for Webflow
Resolved
This incident has been resolved.
Posted May 09, 2023 - 14:02 UTC
Monitoring
The team has deployed an update and we are monitoring the situation.
Posted May 08, 2023 - 19:57 UTC
Update
We are continuing to investigate some reports of crashing and slowness within the Designer. We are gathering data from affected customers and working to identify the issue. In the meantime, using an incognito or a private browsing window may help reduce the frequency of crashes.
Posted May 08, 2023 - 14:08 UTC
Update
We are continuing to investigate some reports of crashing and slowness within the Designer.

We are gathering data from affected customers and working to identify the issue along with this additional information.
Posted May 08, 2023 - 07:10 UTC
Update
We continue to investigate some reports of crashing within the Designer and Editor. In the meantime, using incognito or a private browsing window and disabling any browser extensions may help reduce the frequency of crashes.
Posted May 07, 2023 - 21:12 UTC
Investigating
Webflow is investigating reports of slowness and crashing within the Designer and Editor.
Posted May 07, 2023 - 19:01 UTC
This incident affected: Designer (Designer, Editor).