Client Billing Temporarily Unavailable
Incident Report for Webflow
Resolved
This incident has been resolved.
Posted Sep 27, 2021 - 18:08 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 27, 2021 - 17:53 UTC
Identified
Some customers are unable to set up client billing or delete existing clients. Our team has identified the issue and is currently implementing a fix.
Posted Sep 27, 2021 - 11:07 UTC
This incident affected: Dashboard.